Перейти к содержанию

Selmarion

Участники форума
  • Постов

    6
  • Зарегистрирован

  • Посещение

Весь контент Selmarion

  1. [17.09.2026 21:08] Поддержка Netcraze: Добрый день. Указание IPv6 в endpoint для VPN-клиентов ещё не реализовано. Есть задача для разработчиков, чтобы это сделать: NDM-4300 В будущих версиях ОС будет реализовано. https://support.keenetic.ru/sprinter/kn-3711/ru/35528-latest-development-release.html
  2. отвечу сам: Клиент SSTP (sstp) установлена версия 1.0.13-16-1. - бинарный файл компонента sstp в прошивке Keenetic скомпилирован без поддержки IPv6-транспорта на уровне сокетов (AF_INET6)
  3. (KeeneticOS 5.02.A.8.0-3 (5.2 Alpha ) Sprinter (KN-3711) EAEU Клиент SSTP (sstp) установлена версия 1.0.13-16-1. Сервер SSTP (sstp-server) установлена версия 1.12-21. Суть задачи: Необходимо поднять SSTP-туннель (клиент) до удаленного сервера поверх транспортной сети IPv6. Использование IPv4 в качестве транспорта в данном сценарии невозможно из-за жесткой зацикленности сетей 4-й версии (пересечение подсетей) на конечной точке. Глобальная маршрутизация IPv6 на самом интернет-центре настроена и РАБОТАЕТ корректно (пинги до удаленного сервера по IPv6 проходят без потерь). Проблема: SSTP-клиент в KeeneticOS отказывается устанавливать соединение через протокол IPv6, требуя исключительно IPv4. Воспроизведение и логи: (config-if)> peer 2001:ХХХХ:ХХХХ:ХХХХ::1 Network::Interface::Sstp error[72679524]: "SSTP0": invalid peer format. * При попытке обернуть IPv6-адрес в квадратные скобки парсер также выдает ошибку формата. Если использовать доменное имя, у которого есть только AAAA-запись (или привязать домен к IPv6 локально через ipv6 host), SSTP-клиент зависает в статусе fail: resolve: show interface SSTP0 link: down state: up fail: resolve local-endpoint-address: 0.0.0.0 remote-endpoint-address: 0.0.0.0 Судя по всему, резолвер SSTP-клиента жестко запрашивает исключительно A-запись (IPv4) и полностью игнорирует AAAA, из-за чего не может получить адрес и уходит в отказ. Команда ip host для локального маппинга также не поддерживает IPv6-адреса, требуя только IPv4. Вопрос: Существует ли на данный момент какой-либо workaround в CLI (возможно, недокументированный синтаксис), чтобы заставить SSTP-клиент инициировать подключение по AAAA-записи или напрямую по IPv6-адресу?
  4. Спасибо, большое учтём в маршрутизации, премного благодарен.
  5. Да , модуль стик Keenetic Plus DECT - определился, но вот отвалился канал SIP от оператора Мегафон (Мультифон) - при этом API - запросы прошли на ОК. https://sm.megafon.ru/sm/client/status?login=79036622338&password=пароль (результат приложил).
  6. Аналогично , есть проблема с ошибкой: "Для работы телефонной станции подключите к интернет-центру USB-модуль адаптера телефонии." - не работает стик DECT, обновлён до МодельOmni (KN-1410) EA Сервисный код006-041-748-882-903 Версия ОС3.7.5 Апр 23 00:56:48 kernel usb 2-1: New USB device found, idVendor=0586, idProduct=3428 Апр 23 00:56:48 kernel usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3 Апр 23 00:56:48 kernel usb 2-1: Product: Keenetic Plus DECT Апр 23 00:56:48 kernel usb 2-1: Manufacturer: ZyXEL Апр 23 00:56:48 kernel usb 2-1: SerialNumber: S155729001091
×
×
  • Создать...

Важная информация

На этом сайте используются файлы cookie. Нажимая "Я принимаю" или продолжая просмотр сайта, вы разрешаете их использование: Политика конфиденциальности.